DebugBar Forums
 
 HOME 
 DOWNLOAD 
 BUY 
 DOC / WIKI 
 FORUM 
 CONTACT 
Stay tuned : rss feed

Forum Home


advanced search

You are not logged in.

Announcement

Forums are now closed as we moved them to google groups. You can use the following Google Groups to discuss about DebugBar and IETester products:

#1 2008-01-20 10:30:12

levseltzer
New member

unable to view debugbar

I do not see the debug bar, not do I have an option to display this toolbar. I've tried versions 4 and 5, rebooting in between, with no positive results.

What could be wrong?

Offline

 

#2 2008-01-20 17:01:10

fabrice
DebugBar Support

Re: unable to view debugbar

Hi,

Here are some tips that can help :

* Do you have admin rights on your machine ? If not, try with an admin machine. DebugBar should be registered on non admin machines, but I've got some reports for users where it is not working sometimes.

* Do you have "DebugBar" on the View/Toolbars menu ? If it is grayed, this is because the add-ons is disabled. You can enable the add-on and should be able to open DebugBar.

Which OS and IE version are you using ?

Thanks.

Offline

 

#3 2008-01-20 17:16:38

levseltzer
New member

Re: unable to view debugbar

I am logged in as an admin.
I do not see the option on the view menu.
the debugbar add-on is enabled.
Windows XP Pro SP2
MSIE7.0.5730.11

Offline

 

#4 2008-04-07 03:27:24

Vandal
New member

Re: unable to view debugbar

levseltzer :

I do not see the debug bar, not do I have an option to display this toolbar.

+1 sad

fabrice :

Do you have admin rights on your machine ?

Yes, I have

fabrice :

Do you have "DebugBar" on the View/Toolbars menu ?

No, Only in View/Explorer bar

fabrice :

Which OS and IE version are you using ?

Windows 2000 SP4 + Russian MUI, MS IE 6.0.2800.1106 (Rus)

Offline

 

#5 2008-04-07 03:58:03

Max
New member

Re: unable to view debugbar

I see the debugbar as toolbar below IE menu, but nothing happens pressing the DebugBar button (that is, no DevBar).
Add on is enabled, user is admin; IE7, XP-SP2.

I've tried disabling IE Dev toolbar (which does not work either), no luck. ActiveX controls seem all enabled, if that is relevant.

Ideas?

Offline

 

#6 2008-04-07 07:44:55

fabrice
DebugBar Support

Re: unable to view debugbar

@Vandal: There is a bug in DebugBar v5.0; This version needs gdiplus.dll for the toolbar component. I sent you the dll by email. This should correct your problem.
I will correct this problem on the next release.

@Max: There are several add-ons for DebugBar, be sure to have all "DebugBar ..." items in the add-ons manager enabled. I don't see any reason why the DevBar does not show, that is really strange.
You can try to install again DebugBar (maybe registration was not ok for the DevBar component), and logoff/logon maybe IE has not refreshed its cache (I don't think so, but let's try that...)

Offline

 

#7 2008-04-07 14:31:25

wysocki
New member

Re: unable to view debugbar

I also do not see Debugbar - anywhere. Installed/deinstalled it twice. XP sp2 IE6. Firefox is default browser. I have gdiplus.dll in system32 folder.

Offline

 

#8 2008-04-07 17:39:13

Max
New member

Re: unable to view debugbar

Re: DevBar not showing.

Both components are enabled. Tried deinstalling, reinstalling & registering again, rebooting, etc.: same thing, no err msg or anything. The other buttons like ViewSrc, Color are there and OK.

There must be some quirk in my sys, I also tried IE Dev Toolbar and button shows but nothing happens.

Pls give me an idea where to look in IE config.  FF is my def browser,  gdiplus 5.1 is installed...

Offline

 

#9 2008-04-08 02:01:22

Vandal
New member

Re: unable to view debugbar

It's work!! Thanks a lot!!
After placing gdiplus.dll in system folder reinstall is required

Offline

 

#10 2008-04-08 09:39:39

fabrice
DebugBar Support

Re: unable to view debugbar

@wysocki: That is really really strange. Do you see "DebugBar" entries in the "View/toolbar" or "View/explorer bar" menu ?
I just tried on a fresh XPSP2 IE6 install and it is working on my side. Do you have other IE add-ons installed ? Do you have admin rights on the machine when installing DebugBar ?

@Max: Your problem is also really strange. Do you have some security setup on your machine ? Do you have have some entreprise anti-virus installed on your machine ?

Offline

 

#11 2008-04-10 01:44:10

Max
New member

Re: unable to view debugbar

No enterprise anti-virus, just plain McAfee (and anyway, no warning of any kind).

Security setup? I have enabled all activex, .net extensions &c that I can think of in the Security tab for local intranet, and still no DevBar... The DebugBar button looks like it is pressed, but nothing happens; shouldn't you give a warning, look at an err condition, or something?

Offline

 

#12 2008-04-10 18:18:42

wysocki
New member

Re: unable to view debugbar

Ahh! I still don't see anything in view/toolbar, but view/explorerbar DOES have it. And it works! Can't figure out why there's no toolbar though. In fact, I thought I would have also had an Acrobat toolbar there since I have Acrobat 8 full version installed, but it's not there either. What could cause blocking of toolbars being listed there?

Offline

 

#13 2008-04-14 09:36:05

fabrice
DebugBar Support

Re: unable to view debugbar

@Max : If the "DebugBar" button is pressed, that is IE is reporting DebugBar panel opened. If you don't see it, I am really lost. If you have process explorer installed, can you check if "DebugInfobar.dll" is loaded into the iexplore.exe process ?
The only solution I can propose is to send you a custom version of the dll that will generate some logs so I can see where is the problem getting the logs generated.

@wysocki: So developer panel of DebugBar is working. right ? You don't see DebugBar toolbar. Do you have other IE toolbar installed ? Do you see them ? I don't remember if you have "manage add-ons" on IE6 with XPSP2. If so, check if DebugBar add-ons are all enabled.

Offline

 

#14 2008-04-14 15:06:22

bhagany
New member

Re: unable to view debugbar

Just thought I'd chime in - I'm having the same problem as Max.  That is, I press the DebugBar button and the DevBar doesn't show up.  I'm running IE 7.0.5730.11 on XP SP2.  I installed as local admin, but I'm running as an unpriveleged user.  For what it's worth, a coworker of mine is doing exactly the same thing, except using IE6, and it works just fine.  Our environments are exactly the same otherwise.

edit:  Just checked to see if DebugInfoBar.dll is loaded into iexplore.exe, and it is.

Last edited by bhagany (2008-04-14 15:10:51)

Offline

 

#15 2008-04-14 19:33:52

fabrice
DebugBar Support

Re: unable to view debugbar

Looks like a non ending story.
Maybe installing as admin and then using as non admin may generate troubles. Can you try to log as admin and check if this is working ?

I will try to setup a custom version that is generating logs and send to you (maybe in a few weeks, I don't have time so far...., I'll try to do my best.)

Offline

 

#16 2008-04-14 20:31:45

bhagany
New member

Re: unable to view debugbar

Ah, yes, running as admin works.  I'll use that as a workaround for now, but they kind of discourage that kind of thing around here.  I appreciate you taking the time for a custom dll - let me know when you have a chance to get around to it.

Thanks,
Brent

Offline

 

#17 2008-04-14 22:13:55

fabrice
DebugBar Support

Re: unable to view debugbar

Fine. I know what's wrong. Looks like registration is not working 100%. I will do some tests and try to correct the problem on a future release.

@Max & @wysocki : Do you have the same problem/solution ? or is it a different bug ?

Offline

 

#18 2008-04-15 14:22:02

fabrice
DebugBar Support

Re: unable to view debugbar

@bhagany : Can you try to install again DebugBar using your standard user account ? This may work.

I also checked other toolbars, like Google Toolbar, and they have the same problem. Installing as admin and then using the toolbars in a standard account is not working :-(

Offline

 

#19 2008-04-18 02:00:05

Max
New member

Re: unable to view debugbar

Re: debugbar not showing

I only use this machine as admin (so, yes, installed and used as admin).

Checked SysInfo / SoftEnv / Loaded Modules, and both DebugInfoBar, ToolBar.dll appear listed when IExplore is running. Is that how you wanted me to "check if DebugInfobar.dll is loaded into the iexplore.exe process"???

Offline

 

#20 2008-04-18 21:19:38

wysocki
New member

Re: unable to view debugbar

I'm always logged in as Administrator. IE6 under SP2 DOES have the manage add-ons and Debugbar was enabled. Although I had Acrobat toolbar also in the list, IT did not appear under the view menu either. As a test, I installed the Google toolbar then Debugbar and others suddenly were visible under the view menu. I removed the Google toolbar and everything else is still there. So it's fixed now, but I don't know why the toolbars didn't show up under view in the first place.

Offline

 

#21 2008-04-22 06:19:16

Max
New member

Re: unable to view debugbar

Re: my post of 2008-04-17, should have said "DevBar not showing".

Still have the same problem. Admin yes, both dll loaded. No more ideas?

[I use FireFox+Firebug, which work like a charm; but I do need to debug some quirky IE behaviours]

Offline

 

#22 2008-04-22 06:28:50

fabrice
DebugBar Support

Re: unable to view debugbar

Unfortunately, I don't have any ideas of what can cause the problem.

Do you also have Companion.JS installed ? Does it shows the panel at the bottom of IE ?

Offline