DebugBar Forums
 
 HOME 
 DOWNLOAD 
 BUY 
 DOC / WIKI 
 FORUM 
 CONTACT 
Stay tuned : rss feed

Forum Home


advanced search

You are not logged in.

Announcement

Forums are now closed as we moved them to google groups. You can use the following Google Groups to discuss about DebugBar and IETester products:

#1 2009-03-19 02:41:03

lechuck
Member

Problems with v0.5

I can't use companion.js
The problem is the same of others in the forum, companion is not conected.

Companion.JS BHO not loaded : PROBLEM
JS Debugger Thread not running : PROBLEM
JS debugger version : OLD
JS Debugger not connected : LIMITATION - OLD debugger is not working in protected mode
Internet Explorer Version : 7.0.5730.11
Protected Mode : OFF

Wndows XP SP3
.NET Framework 2.0, 3.0 and 3.5 was instaled
Office 2007
On IE settings, was disabled the two script options
MS Script Debuger was installed (scd10en.exe)

any idea?
thanks and very nice work, I use it before without problems and is a veri usefull help for web developers

Alvaro

Offline

 

#2 2009-03-19 07:19:01

fabrice
DebugBar Support

Re: Problems with v0.5

The BHO is not loaded so it cannot work. Go to the "Manage add-ons" window and verify that "Companion.JS BHO3 is not disabled.

Offline

 

#3 2009-03-19 15:01:45

lechuck
Member

Re: Problems with v0.5

@fabrice
Thanks for your reply, in Manage add-ons are all enabled.
Companion.JS  Enable
Debugbar  Enabled
DebugBar BHO Enabled

Offline

 

#4 2009-03-19 15:45:13

fabrice
DebugBar Support

Re: Problems with v0.5

You should have 2 add-ons for Companion.JS :

* Companion.JS
* Companion.JS BHO

It looks like you have only one enabled for Companion.JS. If the second is not present, try to install Companion.JS again to ahve Companion.JS BHO registered correctly.

Offline

 

#5 2009-03-19 17:07:50

lechuck
Member

Re: Problems with v0.5

I install companion many times, but Companion.JS BHO never appear on add-ons manager.
Maybe there are some way to install BHO manually ?
Thanks allot!

Offline

 

#6 2009-03-19 17:55:52

fabrice
DebugBar Support

Re: Problems with v0.5

Are you running with admin rights ? I'll send you the registry entries you can check to verify if the registration is ok or not.

Offline

 

#7 2009-03-20 13:58:15

fabrice
DebugBar Support

Re: Problems with v0.5

Hi,

To check if the BHO registration has been correctly done, you can check the following registry keys :

For the COM component the following keys are needed :
* HKCR/JSDebug.BHOIEInstance.1
* HKCR/JSDebug.BHOIEInstance

For the BHO registration, the following key is required :
* HKLM/SOFTWARE/Microsoft/Windows/CurrentVersion/Explorer/Browser Helper Objects/{ADDEE521-F1CC-4B89-8C88-B2CF625B9163}

Please can you confirm these keys are present ?

Offline

 

#8 2009-03-20 16:42:39

lechuck
Member

Re: Problems with v0.5

Hello, this key does not exists in registry

* HKCR/JSDebug.BHOIEInstance.1
* HKCR/JSDebug.BHOIEInstance

This is the JSDebug in HKCR
HKEY_CLASSES_ROOT\JSDebug.ATLJSDebugPanelInfo
HKEY_CLASSES_ROOT\JSDebug.ATLJSDebugPanelInfo.1
HKEY_CLASSES_ROOT\JSDebug.ScriptLogger
HKEY_CLASSES_ROOT\JSDebug.ScriptLogger.1

And for the HKLM part, I have this:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Browser Helper Objects\{ADDEE521-F1CC-4B89-8C88-B2CF625B9163}
and the key with value :  Companion.JS BHO
and other key with name : NoExplorer and value = 1

There are something that I can make on the registry or for the file system ?
thanks for your help
I appreciate your help

Offline

 

#9 2009-04-02 17:02:00

lechuck
Member

Re: Problems with v0.5

Hello, I still with this problem.
I try to install 0.4.2 version but is the same problem.

Any help on it ?
Thanks

Offline

 

#10 2009-04-03 21:57:39

brikonwall
New member

Re: Problems with v0.5

I am having the same problem.  Any help will be much appreciated.

==================================
Companion.JS BHO not loaded : PROBLEM
JS Debugger Thread not running : PROBLEM
JS debugger version : OLD
JS Debugger not connected : LIMITATION - OLD debugger is not working in protected mode
Internet Explorer Version : 6.0.2900.218
Protected Mode : OFF
========================================

XP SP3, .NET 2.0, office 2003, On IE script debugging is enabled, MS Script Debuger was installed (WGAPluginInstall.exe)

Companion.JS  Enable
Companion.JS BHO Enable
Debugbar  Enabled
DebugBar BHO Enabled

The following registry keys exists:

For the COM component the following keys are needed :
* HKCR/JSDebug.BHOIEInstance.1
* HKCR/JSDebug.BHOIEInstance

For the BHO registration, the following key is required :
* HKLM/SOFTWARE/Microsoft/Windows/CurrentVersion/Explorer/Browser Helper Objects/{ADDEE521-F1CC-4B89-8C88-B2CF625B9163}

Thanks...

- T

Offline

 

#11 2009-04-04 20:32:31

GSS
New member

Re: Problems with v0.5

I get this error, too.

From the "about" box:

Code:

Companion.JS BHO loaded : OK
JS Debugger Thread running : OK
JS debugger version : OLD
JS Debugger not connected : LIMITATION - OLD debugger is not working in protected mode
Internet Explorer Version : 7.0.6000.16512
Protected Mode : OFF

Question: Where is the "Manage add-ons" window in comment #2?

Offline

 

#12 2009-04-05 01:08:13

lechuck
Member

Re: Problems with v0.5

GSS :

Question: Where is the "Manage add-ons" window in comment #2?

To change the status of an add-on or to update an add-on, follow these steps:

   1. Start Internet Explorer.
   2. On the Tools menu, click Manage Add-ons.
   3. Click the name of the add-on.
   4. Use one of the following methods:
          * Click Update ActiveX to replace the add-on with the current version. This option is not available for all add-ons.
          * To enable an add-on, click Enable, and then click OK.
          * To disable an add-on, click Disable, and then click OK.

You may have to restart Internet Explorer for the changes to take effect after you enable or disable an add-on.

Offline

 

#13 2009-04-05 04:56:24

GSS
New member

Re: Problems with v0.5

I see.

The problem with Companion.JS is not caused by it being disabled. However, restarting the browser once more did the trick.

Offline

 

#14 2009-04-05 14:36:33

lechuck
Member

Re: Problems with v0.5

I think maybe there are some incompatibility with other plugin, I don't know, maybe....
Here is my plug-ins list

Code:

Adobe PDF
Adobe PDF Conversion Toolbar Helper
Adobe PDF Link Helper
Bookmarks
CDelHotkeysObject
Companion.JS
DebugBar
DebugBar BHO
Delicious
Delicious Toolbar
Diagnosticar Problemas de conexion
InformationCardSigninHelperClass
Java Plug-in 1.6.0_11
Java Plug-in 1.6.0_11
Java(tm) Plug-In 2 SSV Helper
Java(tm) Plug-In SSV Helper
JQSIEStartDetectorImpl Class
Launch WinHTTrack
MUWebControl Class
QT Tab Standard Buttons
Research
Search Helper
Shockwave Flash Object
SmartSelect Class
Sothink SWF Catcher
Styler Toolbar
Tag
Windows Live
Windows Live Aplicacion auxiliar de inicio de sesion
Windows Live Toolbar
Windows Live BHO
Windows Media Player
Windows Media Player
Windows Media Services DRM Storage Object
Windows Messenger
XML DOM Document
XSL Template

This is the full list, here is the non Microsoft add-on list:

Code:

Adobe PDF
Adobe PDF Conversion Toolbar Helper
Adobe PDF Link Helper
Bookmarks
CDelHotkeysObject
Companion.JS
DebugBar
DebugBar BHO
Delicious
Delicious Toolbar
Diagnosticar Problemas de conexion
Java Plug-in 1.6.0_11
Java Plug-in 1.6.0_11
Java(tm) Plug-In 2 SSV Helper
Java(tm) Plug-In SSV Helper
JQSIEStartDetectorImpl Class
Launch WinHTTrack
QT Tab Standard Buttons
Research
Shockwave Flash Object
SmartSelect Class
Sothink SWF Catcher
Styler Toolbar
Tag
Windows Messenger

Well, I hope we can find some help
Thanks

Offline

 

#15 2009-04-05 16:39:03

fabrice
DebugBar Support

Re: Problems with v0.5

Hi,

Sorry for the delay...

For people having the BHO not loaded, here are the registry keys that are created during install :

Code:

HKCR
{
    JSDebug.BHOIEInstance.1 = s 'Companion.JS BHO'
    {
        CLSID = s '{ADDEE521-F1CC-4B89-8C88-B2CF625B9163}'
    }
    JSDebug.BHOIEInstance = s 'Companion.JS BHO'
    {
        CLSID = s '{ADDEE521-F1CC-4B89-8C88-B2CF625B9163}'
        CurVer = s 'JSDebug.BHOIEInstance.1'
    }
    CLSID
    {
        {ADDEE521-F1CC-4B89-8C88-B2CF625B9163} = s 'Companion.JS BHO'
        {
            ProgID = s 'JSDebug.BHOIEInstance.1'
            VersionIndependentProgID = s 'JSDebug.BHOIEInstance'
            'Programmable'
            InprocServer32 = s '%MODULE%'
            {
                val ThreadingModel = s 'Apartment'
            }
            val AppID = s '{669CCE51-4A7B-4B98-A5C9-B09D042BC7B5}'
            'TypeLib' = s '{E28A997E-924D-4947-92C9-AEED7C64DB78}'
        }
    }
}
HKLM
{
    SOFTWARE
    {
        Microsoft
        {    
            Windows
            {
                CurrentVersion
                {
                    Explorer
                    {
                        'Browser Helper Objects'
                        {
                            {ADDEE521-F1CC-4B89-8C88-B2CF625B9163} = s 'Companion.JS BHO'
                            {
                                val 'NoExplorer' = d '1'
                            }
                        }
                    }
                }
            }
        }
    }
}

where %MODULE% is replaced by the location of the CompanionJS.dll file

Please check if you have all those registry keys.

Offline

 

#16 2009-04-05 18:36:43

lechuck
Member

Re: Problems with v0.5

Thanks @fabrice

Can I copy this code and make a .key file to put this in my registry?
Because I don't have this keys on the registry.

many thanks for your support

Offline

 

#17 2009-04-05 18:44:02

fabrice
DebugBar Support

Re: Problems with v0.5

Yes sure.

Offline

 

#18 2009-04-05 18:44:52

fabrice
DebugBar Support

Re: Problems with v0.5

But, the question is why the install is not writing the registry keys ?

Do you have admin rights on your machine ?

Offline

 

#19 2009-04-05 19:51:58

lechuck
Member

Re: Problems with v0.5

Yes I am an admin user
I try installing using "Administrator" user too and is the same.
I will copy the keys into a .reg file and tell you whats happen

Edit: I copy the texto like you paste in the forum and is not a valid registry format. Can you paste this keys in a valid registry format?
to execute the .reg file and put it on the registry.
My CompanionJS.dll is located in "C:\Archivos de programa\Core Services\Companion.JS" Spanish windows

Thanks

Last edited by lechuck (2009-04-05 20:05:38)

Offline

 

#20 2009-04-06 06:15:48

fabrice
DebugBar Support

Re: Problems with v0.5

Hi,

I have added the registry file to register the Companion.JS BHO : Check out the install page of Companion.JS (section "BHO not registered") to download the file :

http://www.my-debugbar.com/wiki/CompanionJS/Installing

Don't forget to check and change the CompanionJS.dll path if necessary !

Offline

 

#21 2009-04-06 11:45:22

lechuck
Member

Re: Problems with v0.5

@fabrice, Thanks for your help, I found the problem (not the solution yet). The problem is with the registry, access denied.
I have administration access, total access, but for some parts of the registry i haven't access, and one of this parts is the HKEY_CLASSES_ROOT\CLSID\{ADDEE521-F1CC-4B89-8C88-B2CF625B9163}\*

I search for a solution, when I solve this issue I publish them for other users. The problem is not with CompanionJS. I assume some trojan or something like that...

Offline

 

#22 2009-04-06 11:50:54

fabrice
DebugBar Support

Re: Problems with v0.5

Thanks for your feedback. This behaviour is very strange.

Offline

 

#23 2009-04-07 11:52:34

lechuck
Member

Re: Problems with v0.5

Well, I really don't know where is the problem, but I assume some virus, now I make a clear Windows re installation and now I have CompanionJS back again , wow, I missed .... big_smile

Thanks for the support. The problem here was outside of CompanionJS
attn
Alvaro

Offline

 

#24 2009-04-07 14:55:25

brikonwall
New member

Re: Problems with v0.5

I wish re-installing Windows was an option for me.  The companion.js is just not working for me.

Offline

 

#25 2009-04-07 14:57:02

fabrice
DebugBar Support

Re: Problems with v0.5

What does that mean 'not working for me' ? Do you have bottom panel ? what is the About Box information ?

Offline